Exotel Status Board
Home
Dashboard
BETA
19th November 2023
Delhi
Issue observed for 'Incoming Calls' in Delhi Region
Identified at [19/11/23 02:40 AM] with 'Major Outage'
Issue has been resolved at [19/11/23 02:53 AM]