BETA

12th March 2025

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [12/03/25 01:10 PM] with 'Major Outage'

Issue has been resolved at [12/03/25 01:22 PM]