BETA

14th January 2021

Indonesia Issue observed for 'Outgoing Calls' in Indonesia

Identified at [14/01/21 02:00 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [14/01/21 03:00 AM]