BETA

14th January 2021

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [14/01/21 12:29 AM] with 'Major Outage'

Issue has been resolved at [14/01/21 12:39 AM]