BETA

11th January 2021

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [11/01/21 11:14 PM] with 'Major Outage'

Issue has been resolved at [11/01/21 11:34 PM]