BETA

11th January 2021

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [11/01/21 04:55 AM] with 'Partial Outage'

Issue has been resolved at [11/01/21 05:04 AM]