BETA

6th January 2021

Indonesia Issue observed for 'Outgoing Calls' in Indonesia

Identified at [06/01/21 12:54 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [06/01/21 01:34 AM]