BETA

6th January 2021

Indonesia Issue observed for 'Incoming Calls' in Indonesia Country

Identified at [06/01/21 12:54 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [06/01/21 01:24 AM]