Exotel Status Board
Home
Dashboard
BETA
7th December 2020
Karnataka
Issue observed for 'Outgoing Calls' in Karnataka Region
Identified at [07/12/20 06:49 PM] with 'Major Outage'
Issue has been resolved at [07/12/20 07:00 PM]