BETA

27th November 2020

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [27/11/20 01:54 PM] with 'Partial Outage'

Issue has been resolved at [27/11/20 02:04 PM]