Exotel Status Board
Home
Dashboard
BETA
9th November 2020
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [09/11/20 01:24 AM] with 'Major Outage'
Issue has been resolved at [09/11/20 01:44 AM]