BETA

27th October 2020

Indonesia Issue observed for 'Outgoing Calls' in Indonesia

Identified at [27/10/20 10:24 PM] with 'Partial Outage'

Issue has been resolved at [27/10/20 10:34 PM]