BETA

27th October 2020

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [27/10/20 01:34 PM] with 'Major Outage'

Issue has been resolved at [27/10/20 02:04 PM]