BETA

19th October 2020

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [19/10/20 12:04 PM] with 'Partial Outage'

Issue has been resolved at [19/10/20 12:05 PM]