Exotel Status Board
Home
Dashboard
BETA
17th October 2020
West Bengal
Issue observed for 'Outgoing Calls' in West Bengal Region
Identified at [17/10/20 01:04 PM] with 'Major Outage'
Issue has been resolved at [17/10/20 01:05 PM]