BETA

14th October 2020

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [14/10/20 10:34 PM] with 'Partial Outage'

Issue has been resolved at [15/10/20 12:34 AM]