Exotel Status Board
Home
Dashboard
BETA
8th October 2020
Chennai
Issue observed for 'Incoming Calls' in Chennai Region
Identified at [08/10/20 10:40 PM] with 'Major Outage'
Issue has been resolved at [08/10/20 10:49 PM]