BETA

6th October 2020

Pune Issue observed for 'Incoming Calls' in Pune Region

Identified at [06/10/20 11:59 AM] with 'Major Outage'

Issue has been resolved at [06/10/20 12:09 PM]