Exotel Status Board
Home
Dashboard
BETA
5th October 2020
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [05/10/20 10:50 AM] with 'Major Outage'
Issue has been resolved at [05/10/20 10:59 AM]