BETA

16th March 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [16/03/19 10:11 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [16/03/19 10:17 PM]