BETA

5th August 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [05/08/16 08:46 PM] with 'Partial Outage'

Issue has been resolved at [05/08/16 08:48 PM]