BETA

29th June 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [29/06/17 04:35 AM] with 'Partial Outage'

Issue has been resolved at [29/06/17 04:36 AM]