Exotel Status Board
Home
Dashboard
BETA
3rd October 2020
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [03/10/20 12:30 PM] with 'Major Outage'
Issue has been resolved at [03/10/20 12:39 PM]