Exotel Status Board
Home
Dashboard
BETA
1st October 2020
Rajasthan
Issue observed for 'Outgoing Calls' in Rajasthan Region
Identified at [01/10/20 05:48 AM] with 'Major Outage'
Issue has been resolved at [01/10/20 05:58 AM]