Exotel Status Board
Home
Dashboard
BETA
30th August 2020
Delhi
Issue observed for 'Incoming Calls' in Delhi Region
Identified at [30/08/20 11:08 PM] with 'Major Outage'
Issue has been resolved at [31/08/20 01:08 AM]