BETA

27th August 2020

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [27/08/20 12:08 PM] with 'Partial Outage'

Issue has been resolved at [27/08/20 12:10 PM]