Exotel Status Board
Home
Dashboard
BETA
26th August 2020
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [26/08/20 02:48 PM] with 'Major Outage'
Issue has been resolved at [26/08/20 03:18 PM]