Exotel Status Board
Home
Dashboard
BETA
25th August 2020
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [25/08/20 12:09 PM] with 'Major Outage'
Issue has been resolved at [25/08/20 12:10 PM]