Exotel Status Board
Home
Dashboard
BETA
24th August 2020
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [24/08/20 09:18 PM] with 'Major Outage'
Issue has been resolved at [24/08/20 09:28 PM]