Exotel Status Board
Home
Dashboard
BETA
20th August 2020
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [20/08/20 12:30 PM] with 'Major Outage'
Issue has been resolved at [20/08/20 12:38 PM]