Exotel Status Board
Home
Dashboard
BETA
18th August 2020
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [18/08/20 11:18 AM] with 'Major Outage'
Issue has been resolved at [18/08/20 11:20 AM]