Exotel Status Board
Home
Dashboard
BETA
15th August 2020
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [15/08/20 11:50 AM] with 'Major Outage'
Issue has been resolved at [15/08/20 11:58 AM]