Exotel Status Board
Home
Dashboard
BETA
11th August 2020
Mumbai
Issue observed for 'Incoming Calls' in Mumbai Region
Identified at [11/08/20 01:19 AM] with 'Major Outage'
Issue has been resolved at [11/08/20 01:39 AM]