BETA

30th July 2020

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [30/07/20 12:49 PM] with 'Partial Outage'

Issue has been resolved at [30/07/20 12:50 PM]