BETA

28th July 2020

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [28/07/20 10:29 PM] with 'Partial Outage'

Issue has been resolved at [28/07/20 10:39 PM]