Exotel Status Board
Home
Dashboard
BETA
26th July 2020
Mumbai
Issue observed for 'Incoming Calls' in Mumbai Region
Identified at [26/07/20 04:48 AM] with 'Major Outage'
Issue has been resolved at [26/07/20 04:58 AM]