Exotel Status Board
Home
Dashboard
BETA
21st July 2020
Rajasthan
Issue observed for 'Incoming Calls' in Rajasthan Region
Identified at [21/07/20 05:30 PM] with 'Major Outage'
Issue has been resolved at [21/07/20 05:38 PM]