BETA

18th July 2020

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [18/07/20 12:50 PM] with 'Partial Outage'

Issue has been resolved at [18/07/20 12:59 PM]