BETA

18th July 2020

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [18/07/20 07:28 AM] with 'Major Outage'

Issue has been resolved at [18/07/20 07:39 AM]