Exotel Status Board
Home
Dashboard
BETA
15th July 2020
Mumbai
Issue observed for 'Incoming Calls' in Mumbai Region
5 years ago
Identified at [15/07/20 01:19 PM] with 'Major Outage'
Issue has been resolved at [15/07/20 01:30 PM]