Exotel Status Board
Home
Dashboard
BETA
14th July 2020
Delhi
Issue observed for 'Outgoing Calls' in Delhi Region
Identified at [14/07/20 03:40 PM] with 'Major Outage'
Issue has been resolved at [14/07/20 03:49 PM]