BETA

30th June 2020

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [30/06/20 05:18 AM] with 'Partial Outage'

Issue has been resolved at [30/06/20 05:20 AM]