Exotel Status Board
Home
Dashboard
BETA
28th June 2020
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [28/06/20 12:08 PM] with 'Major Outage'
Issue has been resolved at [28/06/20 12:18 PM]