BETA

27th June 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [27/06/17 03:59 PM] with 'Major Outage'

Issue has been resolved at [27/06/17 04:00 PM]