Exotel Status Board
Home
Dashboard
BETA
23rd June 2020
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [23/06/20 11:58 AM] with 'Major Outage'
Issue has been resolved at [23/06/20 12:00 PM]