BETA

25th June 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [25/06/17 08:16 AM] with 'Partial Outage'

Issue has been resolved at [25/06/17 08:18 AM]