Exotel Status Board
Home
Dashboard
BETA
16th June 2020
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [16/06/20 12:48 AM] with 'Major Outage'
Issue has been resolved at [16/06/20 12:58 AM]