BETA

23rd June 2017

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [23/06/17 03:50 PM] with 'Partial Outage'

Issue has been resolved at [23/06/17 03:51 PM]