Exotel Status Board
Home
Dashboard
BETA
12th June 2020
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [12/06/20 01:10 PM] with 'Major Outage'
Issue has been resolved at [12/06/20 01:18 PM]