Exotel Status Board
Home
Dashboard
BETA
10th June 2020
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [10/06/20 07:18 AM] with 'Major Outage'
Issue has been resolved at [10/06/20 07:20 AM]